☆☆☆HILFE☆☆☆ Eine .apk anpassen????

  • Antworten:4
  • OffenNicht stickyNicht beantwortet
  • Forum-Beiträge: 3

02.11.2019, 08:32:44 via Website

Guten Morgen......

Ich wende mich direckt mal an Sie in dem thema worin meine fragen bestehn .....da ich hier in einem änlichem thema der tread geschlossen wurde und ich wegen sowas nicht direckt die schlechten gemüter auf mich ziehen möchte😆 ......also ich weiss das es fast ans elegale heran reicht es aber am ende überhauptnicht in diese richtung gehen soll.....also ich frag einfach mal .......1. Ich will eine app um schreiben ( ich weiss darf ich nicht ) ich will sie nur so um schreiben das die .apk die ich besitze ..sie nur noch für android 5+ oder 6+ existiert (ohne virus)😂 ich weiss dass sie für android 4. existiert hat da ich sie selber zu der zeit bessessen hatte.....sie aber einfach nicht mehr finde (ich hab alles abgesucht sie existiert so nicht mehr .......jetzt will ich die android 6+ apk so um schreiben das sie unter android 4+ funzt sie dann einmal kopieren aufs smartphone ballern und installieren .......nix am quellcode oder so rum basteln oder sonstwas verstecken ......nur eine 4er version aus einer 5er oder 6er machen das ist meiner meinung nach nicht illegal oder ???? Könnten sie mir da irgendwie vieleicht ein paar tips geben wie ich das am besten anstelle....ich weiss das es sowas wie appdowner.apks existieren aber da ist das problem das ich von der apk keine android4 version davon ohne virus bekommen kann und das andere ist ich will eine installierbare 4 apk version hinbekommen ohne parsingfehler .....ich hoffe das ich mein problem punktuell ausreichend schildern konnte .....das ihr euch ein genügend gutes bild von meinem problem euch darstellen könnt .....und hoffe natürlich um eure hilfe zur lösung meines nicht (Illegalem) vorhaben zu finden...

GRUß
S.

— geändert am 02.11.2019, 08:40:51

Diskutiere mit!
  • Forum-Beiträge: 3.645

02.11.2019, 08:55:17 via Website

Hallo Stamp

Nun , du scheinst Dir den Antworten schon bewusst zu sein, weshalb ich nur noch auf das Technische eingehe.

jetzt will ich die android 6+ apk so um schreiben das sie unter android 4+ funzt sie dann einmal kopieren aufs smartphone ballern und installieren .......nix am quellcode oder so rum basteln oder sonstwas verstecken ......nur eine 4er version aus einer 5er oder 6er machen das ist meiner meinung nach nicht illegal oder ????

Um so etwas umzusetzen, benötigst du den Quellcode , da du das entsprechenden API-Level zum einbinden/complieren benötigst. Zumal dafür der Quellcode auch geändert werden müsste.
Des Weiteren sind die Googleservices unterschiedlich , die Elementar für dein Vorhaben sind.

Ergo : Geht nicht !

P.S. dein Schreibstil ist zum Lesen äusserst anstrengend .

Kein Punkt , kein Komma, kein Absatz und auch keine Groß/Kleinschreibung.
Diese Mühe hättest du dir wirklich schon geben können.

— geändert am 02.11.2019, 09:00:53

Liebe Grüße - Stefan
[ App - Entwicklung ]

Hilfreich?
STAMP3D3, Pascal P. und 1 mehr STAMP3D3Pascal P.Jokel
Diskutiere mit!
  • Forum-Beiträge: 11.167

02.11.2019, 10:31:14 via Website

Wie Stefan schon gesagt hat, kennst du die Antwort ja bereits.
Zudem: Wenn du es schaffst, aus decompiltem (schrecklichem, bis grausamen z.t. obfuscated Code) wieder eine App hin zu bekommen, welche dann auch noch neue APIs unterstützt (4.x+), dann bist du als Entwicker so gut, dass du die App vermutlich mit weniger Aufwand selber schreiben kannst.

Somit gibt es folgende Alternativen für dich:
1. App komplett selber schreiben, erfordert gutes Entwicklerwissen.
2. Da die App unter Android 6.x läuft, kannst du dir auch eine ROM für dein Gerät suchen und flashen, das ist i.d.r weniger Aufwand als eine App zu entwickeln oder gar zu modifizieren.

PS: Um welche App geht es, das dir das so wichtig ist?

LG Pascal //It's not a bug, it's a feature. :) ;)

Hilfreich?
Diskutiere mit!
  • Forum-Beiträge: 3

03.11.2019, 01:00:30 via Website

😅 ja mit satzzeichen hab ichs überhaupt nicht ..... das tut mir auch leid das es so anstrengend zu lesen ist. Vielen Dank auf jedenfall für die schnelle antwort und hilfe....meine fragen sind damit komplett beantwortet da ich mir fast das schon gedacht hab sie selber schreiben zu müssen, die info alleine schon das Abhängigkeiten mit den GAPPS welches android version draus wird....reicht mir mein problem bestimmt eine lösung zu finden ........Danke nochmal

Hilfreich?
Diskutiere mit!
  • Forum-Beiträge: 3

03.11.2019, 01:17:33 via Website

Ja danke auch erstmal für deine hilfe ......fürs verständniss das heist android6+ <<<<<< das plus steht für android oder höhere versionen . Ich benutze android pay systems mit meinem s6edge. Vor her hatte ich ein s3 was jetzt mein arbeitstelefon werden soll. Auf dem s3 ist android 4.3.x glaube ich drauf .die wallet apk um die es sich dreht war vor meiner s6edge zeit aktiv auf dem s3 und hat auch als apk im google play store existiert mitlerweile tut sie dies auch nicht mehr .............aber am ende hat mir deine antwort auch wieder ein wenig die aufen geöffnet eine andere lösung an zu streben ......danke für deine schnelle antwort

Hilfreich?
Diskutiere mit!