Gradle-Warnung, Android-Update

  • Antworten:1
  • OffenNicht stickyNicht beantwortet
  • Forum-Beiträge: 103

19.01.2020, 17:39:58 via Website

Punkt 1:

Folgende Warnung erhalte ich in meiner build.gradle (app) bezogen auf die 2. implementation:

Deprecated Gradle features were used in this build, making it incompatible with Gradle 6.0.
Use '--warning-mode all' to show the individual deprecation warnings.
See https://docs.gradle.org/5.1.1/userguide/command_line_interface.html#sec:command_line_warnings
Es folgt die build.gradle:

apply plugin: 'com.android.application'

android {
compileSdkVersion 26

/*    buildToolsVersion "27.0.3" */
defaultConfig {
    applicationId "example.com.mymapquestapp"
    minSdkVersion 16
    targetSdkVersion 26
    versionCode 1
    versionName "1.0"
    testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"
}
buildTypes {
    release {
        minifyEnabled false
        proguardFiles getDefaultProguardFile('proguard-android-optimize.txt'), 'proguard-rules.pro'
    }
}

}

dependencies {
implementation fileTree(dir: 'libs', include: ['*.jar'])

implementation 'com.android.support:appcompat-v7:26.1.0'

implementation 'com.android.support.constraint:constraint-layout:1.1.3'
testImplementation 'junit:junit:4.12'
androidTestImplementation 'com.android.support.test:runner:1.0.2'
androidTestImplementation 'com.android.support.test.espresso:espresso-core:3.0.2'
implementation('com.mapquest:mapping-android-sdk:2.0.10')
// implementation group: 'com.mapbox.mapboxsdk', name: 'mapbox-android-sdk', version: '8.1.0'
}
android {
compileOptions {
sourceCompatibility JavaVersion.VERSION_1_8
targetCompatibility JavaVersion.VERSION_1_8
}
}

Punkt 2:

ich will meine Android-Version (3.4.1) updaten auf 3.5.3,
werden da Gradle und andere Plugins automatisch mit angepasst ?
Werden alle build-Dateien der Projekte automatisch an die neue Gradle-Version angepasst ?

Bitte um Hilfe !
Gruß Wicki11

— geändert am 19.01.2020, 17:43:37

Diskutiere mit!
Empfohlene Artikel bei NextPit