Veraltete SDK

  • Antworten:6
  • Bentwortet
Robbiani Renato
  • Forum-Beiträge: 602

03.02.2024, 21:45:03 via Website

Hallo zusammen

Wenn ich mein Projekt in den Stor stelle herhalte ich folgende Warnung

Dein letzter Produktionsrelease (13 (1.1.4)) enthält SDK-Probleme

gps data gps data
3. Feb. 2024 21:23

androidx.annotation:annotation:1.0.0

Diese SDK-Version wurde als veraltet gemeldet. Wir empfehlen ein Upgrade auf eine neuere Version (1.0.1 - 1.0.2, 1.1.0-alpha02+).
androidx.fragment:fragment:1.0.0

Diese SDK-Version wurde als veraltet gemeldet. Wir empfehlen ein Upgrade auf eine neuere Version (1.1.0+).

In Build.gradle finde ich aber nichts von diesen Versionen.
Wo muss ich die Versionen ändern?

Gruss Renato

Kommentieren
Beste Antwort
Jokel
  • Forum-Beiträge: 1.527

11.02.2024, 11:20:51 via Website

androidx.annotation:annotation:1.0.0
da wird mir zb
implementation "androidx.annotation:annotation:1.7.1" empfolen

implementation "androidx.fragment:fragment:1.0.0"
zu 1.6.2

— geändert am 11.02.2024, 11:24:30

Hilfreich?
Pascal P.
Kommentieren
Pascal P.
  • Admin
  • Forum-Beiträge: 11.286

10.02.2024, 17:35:35 via Website

Hallo Renato,
wie sieht dein gradle file aus? Vielleicht hat einer deiner Dependencies wieder weitere Anhängigkeiten.
Am besten alle Versionen aktualisieren sofern möglich,

LG Pascal //It's not a bug, it's a feature. :) ;)

Hilfreich?
Kommentieren
Robbiani Renato
  • Forum-Beiträge: 602

10.02.2024, 21:43:53 via Website

Ciao Pascal

Herzlichen Dank für die Antwort.
Im gradle file ist alles aktuell. Ich denke, dass das Problem an einem anderen Ort liegen muss.

Gruss Renato

Hilfreich?
Kommentieren
Jokel
  • Forum-Beiträge: 1.527

11.02.2024, 11:09:42 via Website

Woher willst du das wissen.
Du weißt es nicht und uns zeigst du es nicht.
Dier wird gesagt du sollst eine neuere Version benutzen ob du das machst wissen, sehen wir nicht.

Hilfreich?
Kommentieren
Beste Antwort
Jokel
  • Forum-Beiträge: 1.527

11.02.2024, 11:20:51 via Website

androidx.annotation:annotation:1.0.0
da wird mir zb
implementation "androidx.annotation:annotation:1.7.1" empfolen

implementation "androidx.fragment:fragment:1.0.0"
zu 1.6.2

— geändert am 11.02.2024, 11:24:30

Hilfreich?
Pascal P.
Kommentieren
Jokel
  • Forum-Beiträge: 1.527

11.02.2024, 11:34:38 via Website

In Build.gradle finde ich aber nichts von diesen Versionen.

Das könne auch alte LIBs sein die alte Dependencies benutzen. Eventuell schauen ob der Entwickler eine neue Version anbiedert. Wenn nicht eine andere Aktuelle Lib benutzen und die alte nicht mehr nutzen. Oder selber machen.

Hilfreich?
Pascal P.
Kommentieren
Robbiani Renato
  • Forum-Beiträge: 602

12.02.2024, 20:47:49 via Website

Danke Jokel

Jetzt geht es. Es gab welche Konflikte in der build.gradle. Darum hatte ich einiges entfernt. Aber wenn ich die beiden Libs integriere, dann kommt beim Hochladen keine Warnung mehr.
Nicht lange nachdenken. Es funktioniert und das ist die Hauptsache.

Herzlichen Dank allen die mir geholfen haben.

Gruss Renato

Hilfreich?
Kommentieren